atom 安装nuclide时报错gyp ERR! install error ,解决办法

2016-03-06 16:56:00
hainuo
原创 2847
摘要:gyp ERR! install error
``` apm install nuclideInstalling nuclide to /home/hainuo/.atom/packages gyp info it worked if it ends with okgyp info using node-gyp@2.0.2gyp info using node@0.10.40 | linux | x64gyp http GET https://atom.io/download/atom-shell/v0.34.5/node-v0.34.5.tar.gzgyp WARN install got an error, rolling back installgyp ERR! install error gyp ERR! stack Error: read ECONNRESETgyp ERR! stack at errnoException (net.js:905:11)gyp ERR! stack at TCP.onread (net.js:559:19)gyp ERR! System Linux 4.2.0-1-amd64gyp ERR! command "/opt/atom/resources/app/apm/bin/node" "/opt/atom/resources/app/apm/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "install" "--target=0.34.5" "--dist-url=https://atom.io/download/atom-shell" "--arch=x64" "--ensure"gyp ERR! cwd /home/hainuo/.atomgyp ERR! node -v v0.10.40gyp ERR! node-gyp -v v2.0.2gyp ERR! not ok ```以上解决办法是开启vpn 翻过长城防火墙 原因就是在与这个gyp下载不下来。
发表评论
伍 加 陆 =
评论通过审核后显示。